当页导航

源码安装keystone,生成pki证书出错

[root@linux-node1 keystone]# keystone-manage pki_setup --keystone-user root --keystone-group root

Traceback (most recent call last):

  File "/usr/bin/keystone-manage", line 37, in <module>

    from keystone import cli

  File "/usr/local/python/lib/python2.7/site-packages/keystone/cli.py", line 27, in <module>

    from keystone import token

  File "/usr/local/python/lib/python2.7/site-packages/keystone/token/__init__.py", line 17, in <module>

    from keystone.token import controllers

  File "/usr/local/python/lib/python2.7/site-packages/keystone/token/controllers.py", line 21, in <module>

    from keystone.common import controller

  File "/usr/local/python/lib/python2.7/site-packages/keystone/common/controller.py", line 18, in <module>

    from keystone.common import authorization

  File "/usr/local/python/lib/python2.7/site-packages/keystone/common/authorization.py", line 21, in <module>

    from keystone.contrib import federation

  File "/usr/local/python/lib/python2.7/site-packages/keystone/contrib/federation/__init__.py", line 15, in <module>

    from keystone.contrib.federation.core import * # flake8: noqa

  File "/usr/local/python/lib/python2.7/site-packages/keystone/contrib/federation/core.py", line 19, in <module>

    from keystone.common import dependency

  File "/usr/local/python/lib/python2.7/site-packages/keystone/common/dependency.py", line 29, in <module>

    from keystone import notifications

  File "/usr/local/python/lib/python2.7/site-packages/keystone/notifications.py", line 21, in <module>

    from oslo import messaging

  File "/usr/local/python/lib/python2.7/site-packages/oslo/messaging/__init__.py", line 18, in <module>

    from .exceptions import *

  File "/usr/local/python/lib/python2.7/site-packages/oslo/messaging/exceptions.py", line 13, in <module>

    from oslo_messaging.exceptions import *  # noqa

  File "/usr/local/python/lib/python2.7/site-packages/oslo_messaging/__init__.py", line 18, in <module>

    from .notify import *

  File "/usr/local/python/lib/python2.7/site-packages/oslo_messaging/notify/__init__.py", line 26, in <module>

    from .listener import *

  File "/usr/local/python/lib/python2.7/site-packages/oslo_messaging/notify/listener.py", line 107, in <module>

    from oslo_messaging import server as msg_server

  File "/usr/local/python/lib/python2.7/site-packages/oslo_messaging/server.py", line 26, in <module>

    from oslo_service import service

  File "/usr/local/python/lib/python2.7/site-packages/oslo_service/__init__.py", line 17, in <module>

    from oslo_log import log as logging

  File "/usr/local/python/lib/python2.7/site-packages/oslo_log/log.py", line 48, in <module>

    from oslo_log import _options

  File "/usr/local/python/lib/python2.7/site-packages/oslo_log/_options.py", line 38, in <module>

    help='If set to true, the logging level will be set to '

  File "/usr/local/python/lib/python2.7/site-packages/oslo_config/cfg.py", line 982, in __init__

    super(BoolOpt, self).__init__(name, type=types.Boolean(), **kwargs)

TypeError: __init__() got an unexpected keyword argument 'mutable'

centos6.5 原来python版本2.6  现升级到2.7 安装到这一步的时候报错不知道该如何解决,求大神支招。。之前遇到ImportError: cannot import name messaging等这类错误时都用pip install 限定版本解决了,是不是我的python版本的问题呢,,

1回答

赵海川@新浪云计算赵海川@新浪云计算  项目经理 , 新浪云计算
需要确认当前实际使用的python版本是否是新版本,看报错可能是版本问题:python -V 显示全部

需要确认当前实际使用的python版本是否是新版本,看报错可能是版本问题:

python -V
收起
 2017-01-22
浏览62

提问者

云淡风轻o系统运维工程师, 亿动非凡
评论1

相关推广

  • 灾备中心如何提高资源利用率?
    灾备中心如何提高资源利用率?灾备中心应用和数据部署是否一定要遵循生产端的架构?LinuxONE灾备云解决方案提供一套基于Openstack架构的自动化云平台,实现应用和数据集中部署,为保险和中小银行提供一种新型、简化的灾备架构。点击查看详细解决方案
  • 问题状态

  • 发布时间:2017-01-04
  • 关注会员:2 人
  • 问题浏览:571
  • 最近回答:2017-01-22